Understanding SDM interface

sdm1

SDM

 

Docking and floating panes

SDM uses “docakble” panes to display properties and other information for working with user dictionaries entries. These dockable panes can be moved around independently, or they can be docked to the SDM application window.

Right-click on the title bar of a SDM window to display a popup menu.

sdm2

Opening multiple dictionaries

You can open multiple dictionaries at the same time.Each dictionary will appear on a tab in the main SDM window. Click on a tab to view and work with that dictionary.

sdm3

Working with the SDM panes

Dictionary panes can be placed in different positions on the SDM window.

1. Right-click a dictionary tab to open a popup menu.

2. Select a display option from the popup. You can also click, hold and drag a dictionary tab to move it to a new location.

sdm4

3. Right click on an any dictionary pane to open a popup menu. You can then set this pane to hide or float. You can also click, hold and drag any SDM pane to move it to a new location.

hide_floating

SDM command menus

The SDM menu bar includes six dropdown menus: File, Edit, View, Dictionary, Window, Help

  • File Menu:

     
    sdm6

  • New Create a new dictionary
    Open Open an existing dictionary
    Save Save the current dictionary
    Save As Save the current dictionary with a new name
    Save All Save all open dictionaries
    Publish Publish the current dictionary
    Close Close the currently open dictionary
    Print Print the currently open dictionary
    Print preview Preview the print layout
    Page setup Set up the dictionary page layout
    Import… Import a file into the active dictionary or create a new dictionary
    Export… Export the active dictionary
    Exit Close SDM
  • Edit Menu:

     

    sdm7

  • Undo Undo most recent edit
    Redo Redo most recent undone edit
    Cut Cut an entry
    Copy Copy an entry
    Paste Pate an entry
    Delete Delete an entry
    Select All Select the entire dictionary
    Find Find text
    Replace Replace text
    Find next Find next instance of text
    Display Duplicate entries Display duplicate entries in the dictionary
    Search all dictionaries Search for a term in all dictionaries
    Formatting Font
    Link
    Clear Formatting
    Lookup Operators URL Operator
    Find Operator
    Number Operator
    Quote Operator
    Phone number Operator
    Chemical Formula Operator
  • View Menu:

     

    sdm8

  • Dictionary Columns Select columns of information to display in the main screen
    Entry properties Display a panel showoing entry properites (part of speect, etc)
    Textual Lookup Operators Add a reference to a complex entity (e.g.numerical) included in a UD entry
    Mark headwords Mark the headwords in each entry
    Autosize Row Heights Select to have SDM automatically set the height of the dictionary entry rows
  • Dictionary Menu:

     

    sdm9

  • Dictionary Properties Select columns of information to display in the main screen
    Code selection Code a selected entry
    Code All Code all of the dictionary entries
    Change Entry Type Multinlingual
    Do Not Translate
  • Window menu:

    The Window menu allows you to close, display, and arrange multiple dictionaries in the SDM environment.

    sdm10
  • Help menu:

    The Help menu allows you to display version information for SDM and to link direclty to SYSTRAN’s online support.
    help menu sdm
     
     
     
     
     

(Visited 940 times, 1 visits today)